« Migrating Virtual Server 2005 to Hyper-V | Main | ASP.NET MVC 1.0 Release Candidate Now Available »

January 22, 2009

Comments

Feed You can follow this conversation by subscribing to the comment feed for this post.

Karl

I've spent almost a week (I know, it's really pathetic) installing the hyper-v-role with only failures as you describe it.
It looks like success but in the end, it's failure, reverting changes.

WHY?

Venketash Ramadass


Hi there Karl,

With this issue is it when installing the role itself or when installing the update? Are there any clues in the event log?

Thanks,

Venketash (Pat) Ramadass
emediaIT
http://www.emediait.com

Karl

Hi there,

It's actually when I try to add the role itself.
When I look into the eventlog, I cant really see anything that indicates the problem.
I've checked the eventlog but I cannot see anything specific...not apart from the line stating that a reboot is required...

Any ideas to why this is happening?

Thanks,
Karl

Venketash Ramadass

Hi there again,

With the errors/issues we had it was actually because the pre-RTM version had been installed and was in use with VMs running etc. I have not come across this issue, i.e. when installing the role itself. Is the server completely updated and is it Hyper-V RTM?

Thanks,

Venketash (Pat) Ramadass
emediaIT
http://www.emediait.com

Rick

Hi Karl,

What edition of 2008 are you running? Is it the one that comes with the Action Pack?

Regards,
Rick

Karl

The server is a Windows Server 2008 Standard 64bit (hence with Hyper-V) and the ISO is from MSDN so nothing out of the ordinary actually.

It's so strange that I cant even add the role...

Venketash Ramadass

Hi there again,

The version of Hyper-V that ships with Server 2008 was not RTM at the time. Have you installed all updates, i.e. from Windows Update/your WSUS server?

Thanks,

Venketash (Pat) Ramadass
emediaIT
http://www.emediait.com

Karl

Hi again,

I've run windows update several times and there is no more available updates so I assume it must be all up to date.

Karl

Also, I've downloaded and tried to install:
"Hyper-V Update for Windows Server 2008 x64 Edition (KB950050)" but that one just stops with "The update does not apply to your system"

So, as far as I can see, I cant even patch my system...

Venketash Ramadass

Hi there,

With that last error, i.e. "The update does not apply to your system", it seems like it could either be because a) it's already installed, which you can of course check in Add/Remove Programs or b) the server itself is not RTM. Someone else experienced it at...

http://blogs.technet.com/jhoward/archive/2008/03/19/Hyper_2D00_V-RC0-release-is-available-for-download.aspx

Thanks,

Venketash (Pat) Ramadass
emediaIT
http://www.emediait.com

The comments to this entry are closed.